
Arcview GIS Maps to FXC as a Mapped Image 

 

Overview: These instructions demonstrate how to export a ArcMAP GIS image  
into AWPS FXC as a state scale mapped Image.  It is anticipated that the state 
scale image will be the standard image for CRH WxStory.  A mapped image in 
FXC will allow users to overlay such AWIPS data as radar, obs and redbook 
graphics.  
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Step 1) Edit your GIS Image using ArcMap and define proper AWIPS coordinate 
 system.    

 a) Be sure to use the proper AWIPS Coordinate System.  Note that you need  
  to obtain your Central Meridian, Standard_Parallel values from your    
  FXC/fsl/data/config/Localizations.txt.  Each location will have different values.  
  The values below are from WFO BOU’s Localizations.txt.  

 
   a) To do this, open up ~/data/config/Localizations.txt 
   b) Note your Scale Name (ie. CONUS, State…etc) 
   c) Note the Projection after the Scale Name 
   d) Note the Central Meridian value after Projection 
   e) Note the Standard_Parallel, or False_Easting values after Central  
    Meridian. 
   f) Note the Standard_Parallel_2, or False_Northing values after  
    Standar_Parallel or False_Easting.  
    
 

  Below list AWIPS coordination values for WFO BOU State Scale: 
 

a) State Scale  - Geo  Lambert (-95.00 25.00 25.00) 

 * Central Meridian  = -95.00 
 * Standard_Parallel_1 =  25.00  
 * Standard_Parallel_2 =  25.00 
 

 b) The example below will demonstrate how to set these coordinates in ArcMap. Note  
  that the example is for a State Scale:  

 



   
 
  1) In ArcMap, click View->Data Frame Properties from the top pull down menu.  

 
  2) Click the Coordinate System tab at the top  
  

   
 
  3) From the Coordination System you will be selecting:  
   North_America_Lambert_Conformal_Conic: To do this: 
 
   a) In the Select Coordinate System Entry Box: Click on the following: 



    1) Select Predefined Layers  
    2) Select Projected Coordinate 
    3) Select Continental 
    4) Select North America 
    5) Select North_America_Lambert_Conformal_Conic 

 
  4) Once loaded, select Modify on the right hand side.  This will bring up another  

   window. You will need to change the following values: 
 
    1) Change the Central Meridian value to -95.00000  
    2) Change the Standard_Parallel_1 value to 25.00 
    3) Change the Standard_Parallel_2 value to 25.00 
  

    
 
 
  5)  When done, click OK, followed by Apply and then followed again by OK.  

 
 
  

  
 
Step 2) Define upper left and lower right crop points. These points will appear on  
 the image that is exported and you will use points as a guide to crop your  
 image for AWIPS.   



 
 a) Be sure your ArcMap Tools toolbar is available to you.  The image below  
  describes the appearance of the ArcMap 9.2 Tools toolbar.  
 

   
 
 b) If you do not see this toolbar, it may not be enabled.  To determine this: from  
  the ArcMap top menu: 
 
  1) Select the View pull down menu, followed by toolbars and then finally  
   Tools.   

 
  2) Note that this Tool menu works as a toggle. A check next to a tool  
   denotes a tool that is loaded, or available.  If the Tools toolbar does  
   not have a check to the left, then simply left click on Tools. A check  

   will then appear and the tools will be ready for use.  
 
 c) Determine your upper left and lower right values.   
 
  1) To do this, in your AWIPS FXC directory, open up     
   /data/local/localapps/XXX/FXC/fsl/data/config/Localizations.txt,  
   where XXX is your 3 letter site identifier.  See example below: 

 
 

 
 
   
Step 3) Locate your Scale Resolution and note the lat/lon values at the end of the  

line.  The first set of lat lon values is your upper left and the second set of 
lat/lon values is your lower right values.  

 
 d) On the Tools bar, click on the XY Tool outlined in Red Below.  
   

   
 

 e) This will launch the XY Tool outlined below. 



 

   
 
 f) Once loaded, first click on the Units Pull down menu (Outlined in Red) and  
  select Decimal Degrees.  
 
 
 g) Define Upper Left corner point: Enter your upper left corner Longitude and  
  Latitude values gathered from above.  When done, click on the Add  
  Point button outlined in red below. Once pressed you will note a dot on  

  your ArcMap Spatial Editor.    
   

   
 
 
 h) Define Lower Right corner point: Enter your upper right corner Longitude  
  and Latitude values gathered from above.  When done, click on the Add  
  Point button outlined in red below. Once pressed you will note a dot on  

  your ArcMap Spatial Editor.  
   

   
 
 i) Once done, you will see two dots in your spatial editor. You are ready to export  
  your map in step 3 below.  
   
 
 
  
Step 4)  Export your Map as a PNG Image 
 
 a) Center your Map as desired. Be sure both upper left and lower right points are visible.  
 
 b) From top ArcMap pull down menu, click on File, followed by Export Map.  You will  
  next see the Export Map Window as shown below.  

 



   
 
 
 c) In the Save as Type pull down menu, select PNG 
 
 d) Choose a filename and location to store your file. You can use the defaults, just  

  remember your filename and the location of the PNG you create. 
 
 e) For resolution, select or enter 600 dpi. Note: This will create a large file. This is ok,  

  as the higher the resolution, the better FXC zoomed images will appear.  
 
 d) Click Save to save your PNG Image 

 
 
 

Step 5) Export the Image you created in Step 2 to AWIPS 
 
 a) Secure copy the image you saved above to your LDAD. 
 
 b) Secure copy your image from LDAD to into AWIPS.  I would suggest importing your  
  image to the /tmp directory on your AWIPS workstation. 

 
 

 
Step 6) Crop the Image you imported into AWIPS using GIMP 
  
 Notes: Once the image is brought over to AWIPS, the image needs to be cropped to  

  line up with the Scale you save the image as.  This is a bit of tedious trial and 
error process.  In addition, you will need to be sure your image is finally 
saved with a square resolution.  In other words, save your image as 
3000x3000, or 4000x4000, etc. The numbers do not really matter, but your 



image will not appear in FXC if it is not square. To do this, I would suggest using 

GIMP, which is an IMAGE editor that is available in AWIPS.   

 

 a) In one window, Launch D2D: Select the scale your image was saved as  
  (ie. State).  
 

   
 b) In another window, Launch GIMP: To do this: 

 
  * cd /tmp (This is where the directory of the image you created above is stored) 

 
  *  From an AWIPS terminal, type gimp yourimage.png (Where yourimage.png  

   is the name of the image you have stored)  
 

 c) Once GIMP is open, if your file doesn’t automatically load, do the following: 
 
  * Click on File->Open and then select the directory where your image from Step  
   3 was saved to (ie. /tmp/yourimage.png).  Once found, click   

   on your image to load it into GIMP.   
 
 
 d) Once open, you will need to select the Select rectangular regions tool. This tool is  

  available by clicking on the rectangle icon below File, or by simply pressing R.  
  

    
 
 
 e) Once your tool is loaded, left click on your upper left point in your image.   
 

f) Once your upper left corner has been identified, left click, hold and dray your mouse  
 button to the lower right point in your image.  See Example Below: 

 



  
 
  * Note your  selection resolution (width x height) in the far lower left your  
   image.  You need to make sure your resolution is a square box. For  
   example 4000x4000.  Otherwise your image will not load in FXC.  
 
 
 g) Once done, save your image.  Again I would save it in your /tmp directory on the  
  workstation you will be importing your image to FXC. 
 

  
 

Step 7) Import GIS Image into FXC: 
  
 a) FXC version 4.4.2 contains a menu/tool that simplifies the process of  
  importing GIS images into FXC.   
 
  1) Launch the FXCinstall Menu. To do this: 
   /data/local/localapps/HWO/XXX/FXC/fsl/linux/FXCinstall 

 
  2) Select Option 0 (Manage System Configuration) 

 
  3) Select Option 9 to Add/delete a Map (On Menu) 

 



  4) Select Option 3 for a mapped GIS Image 
 
  5) Select Option a to add a map 
 
  6) Enter the name for the map. This is the name that will appear on the  
   Maps pull down menu in FXC.  

 For example: Standard_State_GISMap 
 

7) Enter the file name and path of the image.  Note that in Step 6 it was  

 suggested you name and save the png image in /tmp.   
 

 In this case your would enter: /tmp/yourfilename.png 
 

8) Specify the scale.  Enter 4 for the state scale. 

 
 
9) You can choose whether or not you wish to make it load by default.  
 

    
  10) Once done, you will note some feedback from FXCinstall.  You will  
   then be prompted to continue or quit.  If you are done, enter n to  
   quit.     

 

 

b) Define default scale for FXC 

 * You may wish to define a default Scale for FXC.  This will tell FXC to  

  start your session of FXC in this scale upon startup. To do this: 

 

1) Launch the FXCinstall Menu. To do this: 
 * ~/FXC/fsl/linux/FXCinstall 

 

  2) Select Option 0 

 

  3) Select Option 7 to set default scale at startup 

 

  4) Enter 4 for State Scale 

 

 

c) Define default zoom for FXC 

 

 * You may wish to define a default Zoom for FXC.  This is especially true 

  if your office will be using the State Scale Mapped Image most of  

  the time.  

 



1) Launch the FXCinstall Menu. To do this: 
 * ~/FXC/fsl/linux/FXCinstall 

 
  2) Select Option 0 

 

  3) Select Option 8 to set default zoom 

 

  4) Select a to Add 

 

  5) Enter 4 for State Scale 

 

  6) Enter 1 for desired zoom factor 

 

  7) Accept value 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

Appendix A. 

Procedures for manually adding or configuring a GIS image in 

FXC. 

 

a)  Edit and add your image to FXC/fsl/data/config/NWS/MenuAndToolBars.txt 

 1) Go the MENU Maps Section of this file.  You will insert your  

  COMMANDITEM for your map at the bottom of this section.   

 

 2) The COMMANDITEM format is as follows: 

 COMMANDITEM “Pull down Menu Name” LTR “ShortcutKey” “load ImageName” 

 

  

 3) Below is an example of this: 

 COMMANDITEM “HiResTopo_StateColor” H “” “load hiresTopo_statecolor” 

 

  * To break down the command above: 

   a) COMMANDITEM  = the map command trigger 

 

   b) “HiResTopo_StateColor” is the FXC MAP pull down menu  

    Name.  

   c) H is a short cut key. This can be any letter or number 

   d) “”is blank by default.  This can be a short cut key. 

   e) load hiresTopo_statecolor = loads the name  

    hiresTopo_statecolor from /data/keys/Scale.txt described 

     below. Note that the name after load above needs to  

    match name entered in fsl/data/keys/Scale.txt 

 

 

b) Edit and add entry to FXC/fsl/data/keys/Scale.txt  

 1) This file sets a depict key for your product.  Note the description key at the top  

  of this file. 

 

 2) For map images, add an entry to the first available key after KEY 60. So for  

  example, if you see KEY 62 followed by KEY 100, start at KEY 63.  

 

 3) Follow the example below to add your image. Note the explanation key that  

  follows: 



 

  63  4  y   n   P    -   M_IMAGE  -   “hiresTopo_statecolor” 

  

  a) 63 is your unique key number 

  b) 4 is your default Scale (4 is the state Scale) 

  c) y refers to Client supplied.  Just use y. 

  d) n refers to whether the file is preprocessed or not. Just use n. 

  e) P refers to the Projection Type.  P is Plan View 

  f) – refers to Compress Type.  Enter – for no compression 

  g) M_IMAGE is the VISUAL TYPE. Enter M_IMAGE for mapped image.  

   Note that U_IMAGE (Unmapped IMAGES) are used for flat JPG  

    and PNG 

  h) hiresTopo_statecolor refers to the Name of the product.  

 

 

c) Edit and add entry to FXC/fsl/data/config/URLocators.txt 

 

 1) This file matches the depict key defined above to a URL or image.  Note that  

  Keys are in order, so if your key number is 63 or example, you will want to  

  insert it after 62. 

 

 2) Follow the example below: Note the explanation key that follows: 

   

  :0000000063 

  ../data/depictables/backgrounds/hiresTopo_statecolor.png 

 

  a) :0000000063 is your depict key. Note the : and 8 zeros that prefix the  

   number. This is needed.  

 

  b) ../data/depictables/backgrounds/hiresTopo_statecolor.png is the  

   location of you image.  Note the .. at the beginning of the line  

   which highlights a relative path. 

 

 

 

6) Troubleshooting: If your image does not load after following the  

  instructions above, note the suggestions below: 

 

 

 1) Image will not load: 

  a) Be sure there are no spelling mistakes in your configuration files you  

   edited above. 

 

  b) Be sure your image scale/res is an exact square.  For example:  



   3000x3002 will not work, while 3000x3000 will.  

 

  

 2) Image does not line up correctly: 

  a) You may have to re-crop your image using the instructions in step 4  

   above.  Unfortunately there is no easy way to do this.  Trial and  

   error. 

 

 

  

7) Loading Overlay Images (ie. Radar) onto your GIS Images 

  

 1) In order to overlay an AWIPS image (ie. Radar) onto your Mapped GIS  

  Image, you need be sure your combine Image option is checked.  To  

  overlay an image from scratch do the following:  

 

  a) From FXC top menu, select Options 

  b) Under Options, select Image Properties 

  c) In the Image Properties, be sure Combine Image is selected or 

   checked 

  d) Load your GIS Map 

  e) Overlay an AWIPS Map (ie. Radar) 

  f) Go back to your FXC->Options->Image Properties to adjust your  

   image  Opacity.  Note Image 1 is your GIS Map image, while  

   Image 2 will be your Overlay Image.  

 


