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1. Introduction

The Department of Homeland Security (DHS) is funding the Global Systems Division (GSD) to conduct a Geo-Targeted Alerting System (GTAS) Pilot Project to determine how advanced high-resolution meteorological and toxic plume data can be used for emergency preparedness. GTAS is built around a display system that allows users to predict plume dispersion in a weather context, outline areas that require warning, and coordinate the specification and issuance of those warnings between weather forecasters and emergency operations officials. The goal of this project is to use NOAA’s numerical modeling data, high performance computing, and warning infrastructure to provide geo-targeted safety information to specific city neighborhoods that are under a life-threatening condition.
This Guide provides a brief overview of the system architecture and describes the many functions available from the GTAS User Interface. As this system is applied to the needs of various users, some customization of the Main Menu and data selectors has occurred. Slight variations will exist in Main Menu layout and content. 

GTAS features include the conventional capabilities of: 

· Display of diverse data sets (images, observations, and text);

· Interactive display manipulation (zoom, pan, toggle overlays, overlay color);

· Interactive display generation (cross sections, time series, time/height, model soundings);

· Extensive manual graphic and annotation tools;

· Display procedures.

Advanced capabilities of GTAS include: 

· Slide creation and presentation;

· Chat capability;

· Internet access to WWW products

· Display of radar data from any WSR-88D radar;

· Creation and display of JPEG images;

· Independent or collaborative mode of operation.

1.1 Scope

This document serves a guide to the use of GTAS in data display, interactive graphics creation, and forecaster collaboration. Technical details of GTAS architecture and server configuration will be described in separate documents.

1.2 Intended Audience and Assumed User Skills

This guide is intended for use by weather forecasters and other users of hydro-meteorological data. We assume that users of this Guide have a basic understanding of, and experience with, using a mouse to navigate a graphic user interface. This includes such operations as opening, closing, resizing, and moving windows, and selecting items from menus. While GTAS is designed to have a "look and feel" similar to that of the Advanced Weather Information Processing System (AWIPS) Display 2-Dimensional (D2D), found at nationally at the WFOs, knowledge of D2D is not necessary for the successful use of GTAS. However, familiarity with AWIPS D2D and its associated data [image: image200.emf]

and displays would be helpful in learning to use GTAS.

2. GTAS Architectural Overview

Figure 1. GTAS Architecture Diagram

The GTAS System consists of two major components: the client component that allows the user to display and interact with meteorological data and the servers that are responsible to provide various types of data to the client. In the illustrated diagram above, the clients are located at the Local NWS WFO or NOAA Headquarters, the Local EOC and the State EOC. The primary server is located at the NWS Region Headquarters and a backup server is located at GSD. The backup server is intended for use if there is high traffic on the primary or if the primary is inaccessible. 
During a collaborative session each server communicates with the clients independently, i.e., it does not broadcast the data to all clients. As a result, some degradation in performance may occur when a large number of clients are connected for a collaborative session. 

Although the AWIPS Database is the primary and most extensive source of data, GTAS can also obtain data (in image form) from Web servers and integrate data from other sources. Unique additions to the GTAS System are the WRF-NMM High Resolution model data and the HySPLIT model data. These model data outputs are downloaded and stored at GSD and sent to the AWIPS Database. 
GTAS Clients are usually located remotely. In order for a client to connect to a server, the user selects the desired server from the GTAS Menu. Once the connection is made to the server, the client has access to the AWIPS Database at the host office. 
2.1 GTAS Operating Modes

GTAS has three basic operational modes: local, independent, and collaborative. 
· Local Mode - In local mode, the client is not connected to any AWIPS Server. However, the user does have access to selected data from remote Web servers and possibly some local data. This mode is useful for preparing briefing displays that do not require real-time data.  

· Independent Mode - In independent mode, the user is connected to an AWIPS Server that the user has selected from the GTAS Menu. This allows the user to access real-time meteorological data at the remote server. The user can display a variety of data and perform such functions as zooming, panning, changing colors, overlaying graphics, and animation on the client. The GTAS Server can accommodate a number of independent clients. The maximum number of clients is controlled from a menu on the server and is currently set to 4.

· Collaborative Mode - In collaborative mode, the user can perform all of the same functions as in independent mode with the added capability of simultaneously updating or controlling the screen of other users. There is also a chat capability that allows users to exchange text messages. The server can only accommodate one collaborative session at a time. All users connected to a common server are part of the same session. The session can remain active although all clients have disconnected from the server. This allows users to rejoin the session at a later time.

2.2 Input Devices

There are two input devices for the GTAS Graphical Interface: a mouse and a keyboard. 

2.2.1 Keyboard Functions

The keyboard is used to enter text in the Discussion Graphic User Interface for "chat" functionality with collaboration participants. The keyboard is also used to enter AFOS text product identifiers into the text interface. Additionally, the keyboard is used for annotating manually-generated graphics. Most GTAS display functions may be performed using the keyboard by holding the Alt Key and striking the "Hot Key" indicated by an underlined character in every menu and submenu. Finally, certain menu commands may be invoked using "Accelerator Key" combinations listed to the right of the associated menu items; for example, Ctrl+A will toggle looping just as if the user selected the Looping Menu item.

2.2.2 Mouse Functions

The mouse is used in a conventional manner for all other GTAS actions. The mouse functions are designed for a three-button mouse. In the event that GTAS is running on a system with a two-button mouse, middle button functions may be accomplished by depressing and holding the "Alt" Key and clicking with the left button. Two examples of middle-button functions are zooming a display or toggling the Manual Graphics to editable mode. 

Basic display functions of zoom, pan, and un-zoom are performed using the mouse. Clicking the middle mouse button will cause the display to incrementally zoom, centered on the position of the mouse cursor. One click of the left mouse button will incrementally un-zoom, with the resulting display centered on the position of the cursor when clicked. To pan a zoomed display, depress and hold the middle mouse button, then drag the cursor in the desired direction to shift the display. The panned display will center on the location of the mouse cursor when the middle button is released. 

Displayed products may be toggled on and off by placing the mouse cursor over the desired product legend (in the lower right portion of the display) and click once with the left mouse button. To change the color of a graphic overlay or background map, place the mouse cursor on the desired product label and click once with the right mouse button to reveal a pop-up menu with color selections. Additionally, any individual displayed product may be unloaded from the display by placing the mouse cursor over the selected product label and clicking once with the right mouse button, revealing a pop-up menu, and selecting the "Unload" option. 

Other mouse functions are toggling background maps and map legends on and off of the display, and un-zooming to 1:1. These display controls are available in a pop-up menu which is revealed by placing the mouse cursor anywhere in the main display window and clicking once with the right mouse button. The resulting pop-up window offers: 
  

· Show Maps (toggle on or off);

· Show Map Labels (toggle on or off);

· Zoom 1:1.

Summary of mouse button functions: 
· Mouse Button 1 (left) - click to zoom out (un-zoom). The resulting display will be centered on the cursor.

NOTE:  Un-zoom is disabled with any editable graphic (Baselines, Points, Drawing Tools) in the display. Toggle the editable graphic to un-editable to un-zoom.
· Mouse Button 1 (left) - click with cursor over a product legend to toggle that product on or off of the display.

· Mouse Button 2 (middle) - with cursor in the display window, click to incrementally zoom. Zoomed display will be centered on the cursor position.

· Mouse Button 2 (middle) - with cursor over an editable product legend (Baselines, Points, Drawing Tools), click to toggle between editable and not editable.

· Mouse Button 2 (middle) - depress and hold button while dragging cursor to pan a zoomed display. Display will center on cursor when button is released.

· Mouse Button 3 (right) - click with cursor over a product legend to open a popup menu from which you can change overlay color or unload that product from the display.

· Mouse Button 3 (right) - click with cursor anywhere in the display to open a popup window that provides options to zoom out to 1:1, or to toggle map backgrounds and map legends.

3. User Interface Description

To start the GTAS session, double click on the "GTAS" Icon. After a few seconds, the GTAS Window will appear. The GTAS User Interfaces for the WFO and EOC, as shown below in Figures 2 and 2a, respectively, include a Title Bar, Menu Bar, Main Toolbar, Drawing Toolbar, Display Pane, and a Status Bar. GTAS will initialize with several default display settings. All settings and selectors will be described in subsequent sections.


[image: image19.png]



Figure 2. Initial State of the GTAS WFO User Interface

[image: image20.png]



Figure 2a. Initial State of the GTAS EOC User Interface

3.1 Menu Bar

The Menu Bar is located at the top of the GTAS Window, just below the GTAS Title Bar. It is a permanent part of the window and cannot be hidden or relocated. All menus are selected with one click of the left mouse button. The following sections describe each button on the Menu Bar. All of GTAS actions may be performed with selectors in the Menu Bar Pull-Down Menus or by selecting the corresponding button on the Main Toolbar.  

3.1.1 File Menu

The File Menu, shown in Figure 3, provides basic file operations and related functions. It also includes the Exit Button to close the GTAS Window.
· Collaborate… [image: image21.png]




This menu option or icon as shown above and also accessible on the Main Toolbar, when selected runs the application in a collaborative mode. 

Note: To switch from independent to collaborative mode make sure to select the Collaborate button first and then select a Server to connect to. When ending a collaborative session select “No Server”, then the Collaborate button. 
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Figure 3a. EOC File Menu

· Server…


This submenu, shown in Figure 3a, allows you to select a server to connect to.

[image: image23.emf]


Figure 3b. Server Menu
· Load GIF/JPEG/PNG...


This selector opens a window for selecting the desired image file. Any GIF, JPEG, or PNG image available on the local (or NFS mounted) disk can be loaded into the display window. The image will be loaded into the frame currently selected and displayed. By advancing the frames, the user can load different images into each frame. When in collaborative mode, these images are also shared with the other GTAS Clients. A File Browser Menu pops up when this selection is made that allows the user to choose the desired directory and file to be loaded. A User can also click and save any image in a browser and use Ctrl-v to paste into the GTAS display.

· Save as GIF/JPEG/PNG...

Any product or combination of products (i.e., overlays and manual graphics) displayed on the GTAS Display Pane may be captured in GIF/JPEG/PNG format. This allows users to create products that can be placed on a Web server for access by the public or a selected set of users, or to create a slide for use in a slide show. Upon selecting "Save as GIF/JPEG/PNG...", a window appears in which to specify filename and directory to be used.

· Save as Animated GIF...

This allows any sets of images to be saved as an Animated GIF and then published to a website. 

· Send To Web (WFO)
This button automatically sends and/or updates images and animated GIFs to a configured website.
· Send-To-Web Image Options (WFO)
This option allows users to configure how an image displays on the configured website. 

· Close Web (WFO)
Closes the Send To Web application.

· New Procedure...(WFO)

(This is similar to the Procedures feature on D2D, with a few limitations.) The user has the ability to create a procedure that consists of a sequence of products that have been loaded to the large display pane from the GTAS Pull-Down Menus. Data that are overlaid together on the large display pane are called Bundles. Refer to Section 4 for more information and practice modules. 
· View Procedure...(WFO)

This option opens the View Procedures Dialog Box, which contains a list of existing Procedures.

· Copy Procedure...(WFO)

If you want to generate a copy of an existing Procedure, use this option to open the "Procedure to be Copied" Dialog Box. Select the name of the Procedure you wish to copy and press the OK Menu Button. Immediately the New Name for Copy Dialog Box opens in which you can type in a new name for the copied Procedure.

· Remove Procedure...(WFO)

This option allows you to permanently remove a Procedure through the Remove Procedure Dialog Box, which lists all existing Procedures. To remove a procedure, select the procedure to be removed (one click with the left mouse button to highlight the procedure to be deleted), then select "OK."

· New Slide Show...(WFO)

The GTAS Briefing Tool allows you to create a list of image, text, or combined image-text "slides" to be used for presentations and weather briefings. Each slide can be built using D2D weather products, briefing text templates, or imported image files (in JPEG, PNG, or GIF format). Refer to Section 4 for more information and practice modules. 
· View Slide Show...(WFO)

This option opens the View Slide Show Dialog Box which contains a list of existing slide shows.

· Copy Slide Show...(WFO)

If you want to generate a copy of an existing slide show, use this option to open the "Slide Show to be Copied" Dialog Box. Select the name of the slide show you wish to copy and press the OK Menu Button. Immediately the New Name for Copy Dialog Box opens in which you can type in a new name for the copied slide show.

· Remove Slide Show...(WFO)

This option allows you to permanently remove a slide show through the Remove Slide Show Dialog Box which lists all existing slide shows. To remove a slide show, select the name to be removed (one click with the left mouse button to highlight the procedure to be deleted), then select "OK."
· Set Working Folder…(WFO)
Allows users to set a working folder.

· View Briefing (EOC)

This option allows the EOC and other clients on the same server as the WFO to view the WFO’s Briefing that has been saved to the server. Refer to Section 5 for more information and a practice module.

· Set User Information...


Allows users to specify the name to be used for chat sessions. This name is also used by the server to allow or disallow a user to connect to the server. The Set User Information Menu also lets the user select the color to be used for all text generated by the user during a chat session.  You can only change user information when you are not connected to a server (independent or collaborative).

· Log Messages


Diagnostic messages are being generated and recorded for most actions performed by the user. The messages are stored in the /FXC/fsl/data/logs directory. These messages make it possible to troubleshoot the system should an error occur. The logs should be purged regularly to prevent the disk from eventually filling up. The user can disable the logging function each time the system is started by toggling this switch off.

· Exit


This causes the GTAS Client to terminate and close all GTAS Windows displayed on the screen.

3.1.2 View Menu

The View Menu, shown in Figure 4, contains options for manipulating the display. Most of these options are available in the more accessible toolbars, but are intentionally included in the View Menu for design redundancy.
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Figure 4. View Menu

· Clear


This menu option removes all data products from the display pane, leaving only the original map background. This same action is more commonly performed from the Clear Button on the toolbar.
· Set Auto-Update Interval…

This menu option allows users to set a time interval for their display to automatically update with new information regardless of the real-time data automatic update settings. 

· Update

Forces the users display to update with the latest information.

· Auto-Update

Enables the auto-update functionality and defaults to the previous auto-update time interval setting. 
· Paste

Allows the user to paste certain objects or images into the display from outside sources, i.e. the Web. 
· Step Back/Step Forward


These two menu options advance the data frames that are displayed forward or backward through time. The more typical way to perform these same actions are with the Arrow (< >) Buttons on the toolbar.

· First Frame/Last Frame


Use these two menu options to jump to the first or last data frames. It is easier to perform these same actions by using the First Frame (|<) and Last Frame (>|) Buttons on the toolbar.

· Looping


This radio button toggles on/off the animation capability, which can also be performed from the toolbar using the Loop Icon.

· Previous Bundle/Next Bundle


These options can be used when displaying data products through the Procedures feature. Refer to Subsection 4.2 for more information about Procedures.

· Show Line Cursor

During slide shows, users can enable this capability to help keep “line” focus during the Briefing presentation to other users. 

3.1.3 Options Menu

The Options Menu, illustrated in Figure 5, contains selectors for controlling data display characteristics.
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     Figure 5. Options Menu

· Data Scale


This feature, when toggled on (check-marked), causes the next product selected from the data menus to be loaded using its scale which causes the product to be loaded at full resolution. For example, when a single site radar product is selected from the menu, with "Data Scale" toggled on, the radar image will be displayed on a radar-scale map background.

· Display Properties...


This submenu, shown in Figure 6, includes additional submenus that allow you to manipulate the display properties of the GTAS Display Panel.
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   Figure 6. Display Properties Submenu

· Area


AWIPS data is stratified into geographic scales, as shown in Figure 7. The geographic scales are organized to "funnel" in on a specific local area. Each geographic scale may have data sets unique to that scale. For example, METAR data would not be available on a North Pacific scale. Data displayed at higher scales typically contain coarser resolution.
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        Figure 7. Area Submenu

· Load Mode


The Load Mode Submenu is shown in Figure 8.
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Figure 8. Load Mode Submenu

Each time you select a product from the menu, a number of frames (equal to the frame count) are loaded into memory. Normally, each frame is loaded with a sequentially older product. However, sometimes you may want to view products in a different manner. This menu allows you to select from a number of different Load Modes. A brief description of each Load Mode follows. 

· Latest run - Displays forecast data only from the latest model run, but also backfills with frames from previous runs at the beginning of the loop to satisfy the requested number of frames.

· Valid time seq - This Load Mode displays the most recent data and fills empty frames with previous data. For models, it provides the product from the latest possible run for every available valid time.

· No backfill - Displays model data only from the most recent model run time with no backfilling to fill out a loop. Using this Load Mode prevents the mixing of old and new data.

· Previous run - Displays the previous model run, backfilling with frames from previous runs at the beginning of the loop to satisfy the requested number of frames.

· Previous valid - This Load Mode displays the previous model run and fills empty frames with previous model data or analyses.

· Analysis loop - This Load Mode loads a sequence of model analyses, but no forecasts.

· Forecast match - Overlays a model product only when its forecast times match those of an initially loaded product. This Load Mode is available only when another product is already loaded in the large display pane.


· Frames


Use this menu, which is depicted in Figure 9, to select the number of frames to load to a display animation. Keep in mind that longer animation loops take more time to load, so adjusting the frame count to a low value will facilitate faster loading, especially through a modem connection.
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Figure 9. Frames Submenu

· Character Size


It is possible to modify the size of graphical characters with the Character Size Submenu, shown in Figure10.  Please note that if you modify the character size, the volcano mouse-over sensitivity will be affected.  This issue will be addressed in future releases of the VACT tool.
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        Figure 10. Character Size Submenu

· Display Density...


The user can specify the amount of data to be shown on the screen by specifying the appropriate density value. The display density is a relative number and the amount of data displayed is also determined by the window size. 
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Figure 11. Display Density

· Loop Properties...

This menu option opens the Loop Properties Dialog Box, shown in Figure12. Within this dialog box are controls for the various features of an animation. You may alter the dwell at the end of a loop, the speed of animation, and the direction (forward or backward) of the animation.
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Figure 12. Loop Properties Dialog Box

· Image Properties...


This menu option opens the Image Properties Dialog Box, depicted in Figure 13. It contains slider bars allowing you to control the opacity of an image. This feature is particularly useful when several overlays are placed on top of an image. By reducing the opacity of the image, the graphic overlays become more discernable. It is also possible to combine two images by enabling the "Combine Images" selector. When enabled, the next image to be loaded will be combined with the current image. Toggling the selector off will resume normal load operation. The "Lock Image Opacity" selector will cause the opacity of the two images to always add to 100%. Thus, if the opacity of one image is reduced, the opacity of the other image will be increased.
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Figure 13. Image Properties Dialog Box
· Image Color


This submenu, shown in Figure 14, contains a number of pre-defined color tables available for image enhancement. The color table will be applied to the currently displayed image. The user can easily revert to the default image enhancement by selecting the item "Default" from the Color Table Menu.
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Figure 14. Image Color Submenu

· Color Table Editing


This menu shown in Figure 15 opens up a submenu that allows the user to create, edit, or delete a custom color table. The custom color table will be saved and the Image Color Submenu will be updated with the name of the new color table. The color tables can be applied to all images (except TIFF, GIF, JPEG and PNG). In order to create a new color table the user needs to select an existing table (one that is perhaps close to the one desired) and modify it.
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Figure 15. Table Selector Menu

Figure 16 illustrates what a typical Color Table editing window looks like. The user can select a single color index by either clicking on the color bar or selecting the desired index with the thumbwheel selector. If the user wants to select a range of values then the second index can be selected by depressing the shift button on the keyboard while also depressing the mouse button over the desired location on the color bar. Alternatively, the user can enter the desired index into the second thumbwheel selector. The user can select a solid fill or linear interpolation between the two indices by depressing single or linear, respectively. The standard color palette (see Figure 17) will appear and the user can select the desired colors.
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Figure 16. Color Table

Figure 17 shows the standard color menu for selecting background, overlay, and image colors. The user can select a color from one of the swatches, set the HSB values, or define the color by specifying the RGB components. A color swatch on the menu changes color as you adjust the various color components. Once, satisfied with the color the user needs to click on "ok" to save the color setting.
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Figure 17. Display Colors
· Display Size


You can resize a window by either selecting one of the predefined sizes from the Display Size Submenu, shown in Figure 18, or by grabbing the edge of the display and reshaping the window to the desired size. The attributes of a window are saved in a state file to allow the window to reappear in the same location and of the same size the next time the window is opened.
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Figure 18. Display Size Submenu

· Toolbars


GTAS has two toolbars; The Main Toolbar contains the basic controls of the display and a second, the Drawing Toolbar, is used in conjunction with the drawing tool. All of the functions in the toolbar are also available from the Main Menu Bar. It is therefore possible to hide the toolbar and still have access to all of the toolbar functions. The Drawing Toolbar is visible when the Drawing Tool is loaded from the Tools Pull-Down Menu, shown in Figure 19, and is made "editable" (by clicking on the "Manual Product" legend once with the middle mouse button). This is discussed further in the Section 3.1.4, "Tools Menu."
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    Figure 19. Toolbars Submenu

· Change Display Colors


This submenu, shown in Figure 20, allows the user to change the default colors for the display window background (typically black) and the graphic overlays. By selecting the desired item and clicking on "change" the standard color palette (see Figure 19) will appear and the user can select the desired color. The default information will be saved in a state file and will be recalled the next time GTAS is started. If the user wants to change the color only for a particular graphic on the current display, then the user can right click on the product label and change the color of the graphic. Clearing the screen will then set the color back to the default.
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    Figure 20. Display Palette
· Contour Conversion Properties…(WFO)
The Contour Conversion Properties… dialog box, shown in Figure 21, allows the user to change the visual properties of the weather data contour lines. 
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    Figure 21. Contour Conversion Properties

· Set Clock Time…

The Set Clock Time… dialog box, shown in Figure 22, allows the user to change the clock settings to either the current real time or a previous specified time and date.  
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    Figure 22. Set Clock Time

· Restart Dead Pane…
This option restarts any panes that are “dead” or frozen.
3.1.4 Tools Menu

The Tools Menu, shown in Figure 23, provides selectors for interactive GTAS capabilities. Each tool is described as follows.
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 Figure 23. Tools Menu

· Baselines

When selected, a number of interactive baselines appear on the display. If the display is zoomed to a small geographic area, the baselines may not be visible. Un-zooming may be necessary to view and move the baselines. Baselines may be arbitrarily placed for the purpose of creating a vertical cross section from model data through the use of the Volume Browser. Note that one end of the baseline line segment is labeled A through J. The resultant vertical cross section will be displayed with the label end of the baseline plotted on the right side of the cross section. In other words, if a west to east cross section is to be created, and the user wishes the cross section to be displayed with west on the left, position the baseline with the letter label on the right side. 

To move a baseline, first note if the product label indicates "editable" mode, i.e., "Interactive Baselines (editable)." If the word "editable" is not visible, click once with the middle mouse button with the cursor on the product label to toggle the baselines to "editable". Now to move a baseline, place the tip of the mouse cursor on the baseline and click once with the left mouse button. The shape of the cursor will change from an arrow to a hand when the baseline is successfully grabbed. Then relocate the cursor to the desired location of the baseline and click once again with the left mouse button. 

To move a vertex of the baseline, click once with the left mouse button with the tip of the arrow cursor on the end of the baseline to be moved. The cursor shape will change to a cross-hair when successfully grabbed. Then click once more in the desired new location for the baseline end point.   

Note:  To move an editable object (baseline, point, manual graphics glyph/symbol), click once to grab the object; then move the mouse to the desired location for the object, and click again to place it there.
· Points


Similar to the editable baseline, editable points are used to locate model-derived soundings, time series, or time height model plots. Point A is also used in the Data Scale Load Mode for radar images and for displaying model soundings from the volume browser. 


Manipulation of editable points is the same as that for baselines. Make sure the product label indicates "editable", place the tip of the mouse cursor over the point to be moved, and click once with the left mouse button. The shape of the cursor will change from a left-slant arrow to a hand. Move the cursor to the desired location and click once again with the left mouse button.

· Tool-Specific Commands


This selector becomes active when the drawing tool has been selected. The submenu for this selector replicates the drawing tool functions that are also accessible using the icons in the toolbar.  See Section 3.3 for more information on tool functions.

· Drawing


This selector invokes a manual graphics capability. A Drawing Toolbar will appear along the top of the GTAS Display, below the Menu Bar, and the product label "Manual Graphics (editable)" appears in the lower right corner of the display. More information on the drawing features is presented in Section 3.3 and a 
Drawing Tool Practice Module is available in Section 3.4. 
· Dispersion Model…

This option displays the Hybrid Single Particle Langrangian Trajectory (HySPLIT) Run Dispersion Model dialog box. See Section 7 for more information and practice modules on how to run HySPLIT and retrieve the results.
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Figure 24. Run Dispersion Model

· Text Window


This selector invokes an AWIPS Text Window, as illustrated in Figure 25, in which any NWS text product carried on the Satellite Broadcast Network may be displayed. This window may also be used as a "notepad" for creating text. Selectors for easy access to AWIPS Text Products are available under the "Products" Menu. This list may be modified to suit the needs of the local office.
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Figure 25. GTAS Text Window

· Text Chat


Select this button to open a "chat room" window. The GTAS client must be connected to a server and be set to collaborative mode to use this feature. Each collaboration participant will be listed in the Discussion Window, shown in Figure 26.
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Figure 26. GTAS Discussion Window

To the left of the collaborator's name is a small check box that enables an audible alarm whenever a message is received from that user (even if the window is hidden from view). The "Option" selector in the Discussion Window Menu Bar opens a menu that allows users to select a word or combination of words that will alert the user whenever that text string occurs in any of the discussion.

· Ring Bell for All Users, when displayed

Audibly alerts all clients that are connected to the server in a collaborative mode, to the event.
3.1.5 Volume Menu (WFO only)
The Volume Menu, shown in Figure 25, provides access to displays of graphics created from model grids.
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Figure 27. Volume Menu

· Browser


This selection opens a window called the Volume Browser (Figure 28) that provides menus from which a vast number of model analysis and forecast fields may be produced. The overall design and functionality is similar to the Volume Browser in AWIPS D2D, with a few exceptions. Selections must be made in order from left to right, first selecting a model or models, then fields, then planes. Displays may be created as graphics or images. Conventional plan view displays, cross sections, time series, time/height sections, and model soundings can be created using selections in the Presentation Menu (Figure 29).
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Figure 28. Volume Browser
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       Figure 29. Volume Browser with Presentation Options Menu

· Families


Choosing DGEX, NAM, or RUC family of graphics results in a display of a selection of eight conventional graphics of upper air and surface parameters from the chosen model. The first two graphic overlays are displayed, while six graphic overlays are suppressed. To toggle a graphic on or off, simply click once with the left mouse button with the tip of the cursor on the product legend.

· Comparison Families


Selecting either 500 Height or MSL Pressure will display a selection of eight graphic overlays from several NWS models. 

· Surface Families


Selecting NAM12 will display a selection of eight graphic overlays from the selected NWS surface model. 

3.1.6 Obs Menu (WFO only)
This menu and associated submenus provide access to a variety of observational products; including METAR Station, buoy plots, tower plots, and lightning displays. Depending on the application, this menu may also provide access to certain Web products (GIF, JPEG). Furthermore, it allows users to overlay (single color) a hand drawn local graphic product into one or all frames using the "Local Graphic" selector. Refer to Figure 30.
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 Figure 30. Obs Menu

3.1.7 NCEP/Hydro Menu (WFO only)
The NCEP/Hydro Menu, shown in Figure 31, contains National Center graphics and analyses.
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Figure 31. NCEP/Hydro Menu

3.1.8 Upper Air Menu (WFO only)
Mandatory level upper air plots, raobs plotted on a Skew-T diagram, Profiler time/height and plan view plots, and selected AWC products are available under this menu, as depicted in Figure 32.
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Figure 32. Upper Air Menu

3.1.9 Satellite Menu (WFO only)
The Satellite menu, shown below in Figure 33, allows the user to display GOES West imagery and 4 Sat Composite products. Spatial resolution of the images is dependent upon the scale at which the imagery is loaded.  
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Figure 33. Satellite Menu
3.1.10 Radar Menu (WFO only)
The Radar Menu in Figure 34 contains selectors for various radar images and products. 
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Figure 34. Radar Menu

 
3.1.11 Dispersion Menu

The Dispersion Menu shown below in Figure 35 allows users to access their latest HySPLIT model runs by choosing their “office type” and then selecting Latest -> Image 1. The Images are numbered depending on how many chemicals they have included into their HySPLIT model run. Currently the chemical limit is set to three. The Latest run will always be the most recent run the users submitted. However, the last 20 runs are saved and the users have the ability to revisit those runs. 
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Figure 35. Dispersion Menu
3.1.12 Maps Menu

This menu, shown in Figure 37 below, allows the user to access a variety of map backgrounds for GTAS Displays.  

A map background may be toggled on or off in two ways. One way is to use the Maps menu. Click once with the left mouse button on a map name on the Maps Menu to toggle on or off the selected map background. The other way to toggle a map background is through a map label in the Product Legend located in the lower right corner of the GTAS display.
If a user selects a GIS shape file map background from the menu and once it displays selects the Change Display Properties Dialog Box, shown below in Figure 36, with the right mouse button popup menus, the user can then perform queries on the shape file attributes in order to highlight intersections or points of interest. Refer to Section 9 for a “Querying the GIS Map Backgrounds” Practice Module. 
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Figure 36. Change Display Properties Dialog Box
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Figure 37. Maps Menu

3.1.13 Help Menu

The Help Menu contains the About... option which opens the About GTAS Window that contains software version and date information. This menu also contains a Help Topics… section that allows a user to refer easily to a certain topic by typing a word or phrase into the Search: box and then hitting Enter on their keyboard. Refer to Figure 38 and 39 below.
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Figure 38. Help Menu
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Figure 39. Help Topics… Window
3.2 Main Toolbar

The Main Toolbar, shown in Figure 40 and 41, is found just below the Menu Bar and provides shortcuts for many of the Display controls found in the Menu Bar. The function of each selector on the Main Menu Bar is identified with "tool tips". Simply move and dwell the mouse cursor over the desired selector and a "tool tip" will appear identifying the selector. 
Some key features of the Main Toolbar include the Collaboration tool, the Send To Web feature, and access to the HySPLIT model through the Run Dispersion Model Dialog Box. 
Users have the option to view the Main Toolbar either horizontally (default) or vertically by disconnecting the Toolbar from the main window and clicking mouse button 3 on the dotted vertical line then selecting either “Horizontal” or “Vertical”. Users can rejoin the Toolbar to the main window by selecting “Rejoin Main Window” or just by closing the Toolbar. 
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Figure 40. Main Toolbar (Horizontal State)
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Figure 41. Main Toolbar (Vertical State)
3.2.1 Server

This allows the user to connect to the desired AWIPS Database. The selector identifies the AWIPS "localization" and geographic location of the GTAS Server. The user can connect to a server that resides on a remote machine or on the same machine as the client.

3.2.2 Collaborate [image: image62.png]



This sets the collaborative mode. All collaboration participants (GTAS Clients) must be connected to the same GTAS Server to utilize Collaborative Mode. Most of the actions by the user are shared with the remote collaborators. For example, a user can load an image, overlay model data, zoom in on a specific area, and then start an animation and have all of these actions performed on the other GTAS Clients who have also enabled collaboration while connected to the same server. Actions that are not currently shared include changing color enhancements and adjusting image intensity. Some of these may be added in the future. Also, with GTAS set to Collaborate mode, a "chat room" capability (labeled "Text Chat…"on the Tools Menu) is available that allows users to exchange textual messages and determine who is participating in the collaboration session. Refer to Section 6 for a “How to Collaborate” Practice Module. 

3.2.3 Send To Web [image: image63.png]



The Send To Web feature allows users automatically update and/or send GTAS display images and saved animated GIF files to a website that has been configured within their GTAS system. 

3.2.4 Dispersion Model [image: image64.png]



The Dispersion Model feature allows users to access the Run Dispersion Model Dialog Box where they can run HySPLIT given a set of chemical characteristics. 
3.3 Drawing Toolbar

A variety of drawing and annotation capabilities are available on GTAS through the Drawing Toolbar. When "Drawing" is selected from the Tools Menu, the Drawing Toolbar initially appears at the top of the GTAS Display, just below the Main Toolbar, as shown in Figure 42.
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Figure 42. Drawing Toolbar (Shown in the Default Horizontal Layout)

This toolbar may be "torn away" from the Main Toolbar by grabbing the Drawing Toolbar with the cursor at the left edge by depressing and holding the left mouse button. A vertical or horizontal layout is possible by clicking once with the right mouse button with the cursor in a blank gray area between buttons on the toolbar. The choices "Horizontal", "Vertical", and "Rejoin Main Window" will appear for user selection, as shown in Figure 43.
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Figure 43. "Vertical" Drawing Toolbar


The selectors on the Drawing Toolbar allow the creation, selection, or saving of files and selectors to create, manipulate, and annotate manual graphics. Pausing the mouse cursor over the buttons on the toolbar will reveal tool tips describing the function of each button. 

3.3.1 New Drawing [image: image67.png]



This selection erases the drawn objects and leaves all of the graphic overlays and underlay intact. This is unlike a Clear that erases the overlays, underlay, and removes the drawing tool.

3.3.2 Open Drawing [image: image68.png]



This selection retrieves the object file containing the drawing and displays it on the screen.

3.3.3 Save Drawing [image: image69.png]



A drawing is always saved in two different formats: a graphic metafile and an object file. The object file is retrieved by selecting Open Drawing for additional editing, and the metafile is retrieved as a single color graphics by selecting Manual Graphic from the Surface Menu.
3.3.4 Common Alerting Protocol (CAP) Message [image: image70.png]



After a polygon has been created and closed on the display, users can access the CAP Messaging feature, shown below in Figure 44. The CAP Messaging is version 1.1 compliant, uses XML language, and can be configured to be sent to a vendor, i.e. Reverse 911. The Red fields in the Create CAP Message Dialog Box indicate “mandatory” and the Green fields indicate “optional”. All the mandatory fields must be “green” before the CAP Message can be sent. Refer to Section 8 for a “Creating a CAP Message” Practice Module. 
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Figure 44. Create CAP Message Dialog Box
3.3.5 Undo [image: image72.png]



(32 steps)

3.3.6 Redo [image: image73.png]



(32 steps)  With the following manipulations, first select the function with a click of the left mouse button; then click on the object that is to be manipulated and click again on the final desired location (if appropriate) for the object. 
3.3.7 Center Drawing Cursor [image: image74.png]





The Center Drawing Cursor is a great tool for the Briefer to use during a collaboration exercise.

This tool when clicked upon with the left mouse button + hold can be dragged and dropped to a location of interest. This allows the Briefee to verify what the Briefer is referring to in the Briefing or collaboration exercise. 

3.3.8 Allow Multiple Selection [image: image75.png]



The Allow Multiple Selection tool allows the user to select multiple drawing items on the display. The user can then move, copy, remove, etc. all items selected. 
3.3.9 Move Glyph [image: image76.png]N




3.3.10 Copy Glyph [image: image77.png]



3.3.11 Erase Glyph [image: image78.png]



3.3.12 Edit Glyph/Line [image: image79.png]



This drawing tool allows users to edit any line, front, shape, or contour. To modify an item, click on the spot near the desired location, draw the new item and click when the new item touches the old item. 
3.3.13 Glyph Size [image: image80.png]



Make the glyph (symbol or icon) S (Small), M (Medium), L (Large), X (X-Large).
3.3.14 Line Thickness [image: image81.png]



There are four thickness options available.

3.3.15 Line or Glyph Color [image: image82.png]



A pallet of sixteen colors is available.

3.3.16 Line Types

The "cloud" line type may be drawn as Right or Left orientation. 

· Solid Straight Line [image: image83.png]



· Dashed Straight Line [image: image84.png]



· Straight Arrow [image: image85.png]



· Freehand [image: image86.png]



· Dashed Freehand [image: image87.png]



· Arrow Freehand [image: image88.png]™




· Scalloped [image: image89.png]v




· Ridge [image: image90.png]



3.3.17 Front Types

Front types may be drawn as Right or Left orientation. The default is specified by the pull-down menu to the right of the symbols. "Right" means that the annotations will be to the right of the line as you are drawing it. The orientation can be changed after the line is drawn by clicking on the line with the right mouse button and selecting the desired "Decoration Side.." from the pop-up menu. 

· Surface Cold Front [image: image91.png]



· Aloft Cold Front [image: image92.png]



· Surface Warm Front [image: image93.png]



· Aloft Warm Front [image: image94.png]



· Surface Stationary Front [image: image95.png]



· Aloft Stationary Front [image: image96.png]



· Occluded Front [image: image97.png]



· Dry Line [image: image98.png]



3.3.18 Shape Types

Select this option to draw shapes. When drawing shapes, an additional pull-down menu appears on the toolbar to define the default characteristics of the shape, create shapes with or without borders, and drawn as Hollow, Transparent, Translucent, Semi-opaque, and Opaque. Users can also change the density of the lines that encompass the shape by selecting Sparse, Medium, Dense or Solid.
· Polygon [image: image99.png]



Use the left mouse button to select vertices of the polygon, and then use the right mouse button to close the shape.

· Freehand Polygon [image: image100.png]




Click once with the left mouse button to begin drawing the freehand shape. Then click a second time with the left mouse button to close the shape.

· Circle [image: image101.png]10}




Click once with the left mouse button to begin drawing the circle shape. Then click a second time to end the drawing. The circle shape becomes larger by dragging the cursor away from the origin. 

· Rectangle [image: image102.png]jm}




Click once with the left mouse button to begin drawing the rectangle shape. Then click a second time to end the drawing. The rectangle shape becomes wider and longer by dragging the cursor away from the origin. 

· Cloud [image: image103.png]



Click once with the left mouse button to begin drawing the cloud shape. Then use freehand to draw an area to be enclosed within the cloud shape. Use the left mouse button again to close the drawing. 
3.3.19 Contours

· Contour Path [image: image104.png]



Click once with the left mouse button to begin drawing an open-ended contour. Then click the left mouse button again to end the drawing. Before the drawing is complete, the user is prompted to enter in a contour number, refer to Figure 45. After the number is entered and the user selects “OK”, the contour is complete. 
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Figure 45. Contour Tool Dialog Box
· Contour Polygon [image: image106.png]



Click once with the left mouse button to begin drawing a closed contour. Then click the left mouse button again to end the drawing. Before the drawing is complete, the user is prompted to enter in a contour number, refer to Figure 45. After the number is entered and the user selects “OK”, the two ends are connected and the contour is complete.
3.3.20 Precip Symbols

· Light Intermittent Snow [image: image107.png]



· Light Continuous Snow [image: image108.png]



· Ice Pellets [image: image109.png]



· Freezing Drizzle [image: image110.png]



· Rain [image: image111.png]



· Thunderstorm [image: image112.png]



· Severe Thunderstorm [image: image113.png]IK




· Rain Shower [image: image114.png]



· Blowing Snow [image: image115.png]+|




· Blizzard [image: image116.png]



3.3.21 Aviation Symbols

· Turbulence [image: image117.png]



· Severe Turbulence [image: image118.png]



· Icing [image: image119.png]



· Severe Icing [image: image120.png]



· Light Fog [image: image121.png]



· Fog [image: image122.png]



· Haze [image: image123.png]



· Smoke [image: image124.png]



· Blowing Sand [image: image125.png]



· Blowing Dust [image: image126.png]3




3.3.22 Cloud Cover

· Clear Sky [image: image127.png]



· Scattered Clouds [image: image128.png]



· Broken Overcast [image: image129.png]



· Overcast [image: image130.png]



3.3.23 Combo Symbols

· Rain/Drizzle [image: image131.png]



· Moderate/Heavy Rain [image: image132.png]



3.3.24 Other Symbols

· Low Pressure [image: image133.png]



· High Pressure [image: image134.png]



· Generic Marker [image: image135.png]X




· Dust [image: image136.png]



· Tropical Storm [image: image137.png]


 

· Hurricane [image: image138.png]



· Wind Barb [image: image139.png]~
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Figure 46. Create Wind Barb Dialog Box

Click once with the left mouse button at the desired location of the wind barb. A       Wind Speed selector appears to set the desired speed. Select speed, and then select "OK". The wind barb of selected speed appears adjustable to direction. Place the cursor to indicate the desired wind direction then click once again with the left mouse button. 

The speed and direction of the wind barb can be changed after it has been drawn. To change the speed click on the wind barb with the right mouse button and select "speed" from the pop-up menu. To change the orientation of the wind barb select "Move Glyph" from the drawing tool bar and click on the end of the wind barb with the left mouse button. Rotate the wind barb to the desired direction and click the left mouse button a second time. To change the location of the wind barb follow the same basic procedure but click on the shaft of the wind barb.  The glyph can also be moved or rotated by using the “move” command available in the pop-up menu.

· Image (access to wxicons) [image: image141.png]



This icon allows users to access the icons directory that includes the wxicons directory. Click once on the display where the image will be placed, the Open Dialog Box appears as shown in Figure 47. Choose an icon to display and then select “Open”. 
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Figure 47. Open Dialog Box
3.3.25 Text

· Create Annotation  [image: image143.png]abe





Click once with the left mouse button at the desired location of the annotation, then a Create Annotation Dialog Box, as shown in Figure 48, appears for entering the annotation text. Enter desired text and click "OK".

[image: image144.png]% Create Annotation





Figure 48. Create Annotation Dialog Box

· Point Size [image: image145.png]12w




· Bold Face [image: image146.png]A




· Italics [image: image147.png]



· Orient Along Latitude [image: image148.png]



· Shadowed [image: image149.png]



· Shadow Color [image: image150.png]



3.4 Drawing Tool Practice Module

One of the powerful features of the system is its ability to annotate a display with graphics or text using the Drawing Tool. The objective of this module is to introduce you to some of the basic drawing capabilities. 

[image: image151.png]



Figure 49. Sample Drawing

Steps:

1. From your desktop, open GTAS.

2. From the Main GTAS Toolbar, clear the GTAS Display Window.

3. From the Area Options Menu, select the CONUS ([image: image152.png]conus



) scale.

4. From the Tools Menu, select the Drawing option (or depress CTL-D). The Drawing Toolbar automatically appears, and contains many useful features for drawing lines, fronts, symbols, etc. Once this toolbar is active, the functionality of the Left Mouse Button changes to accommodate the drawing and editing of the drawing features.

5. From the Drawing Toolbar, open the Glyph Choices Options Menu (label changes to reflect type of glyphs) and select Lines [image: image153.png]Lines.



 (Default). Notice the icons to the right change to reflect several line types. Click on the Straight Line Icon ([image: image154.png]


).

6. Down in the GTAS Display Window, click the Left Mouse Button somewhere on the display and notice the cursor becomes a pencil, and that one end of your line is anchored in the location where you clicked. Now move the mouse to another place and click again to anchor the other end point of your line.

7. In the Drawing Toolbar, open the Color Options Menu (colored line) [image: image155.png]


 and select a different color, say red.

8. Now click on a different Line Type, like the Dashed Freehand Icon ([image: image156.png]


). Repeat Step 5.

9. Under the Glyph Choices Options Menu, choose Precipitation Symbols ([image: image157.png]Precp v



). Notice how the icons change in the Drawing Toolbar. Click on the Freezing Drizzle Icon ([image: image158.png]


).

10. Again, open the Color Options Menu and select the blue color.

11. In the Glyph Size Options Menu (single letter button) [image: image159.png]


, select L (large).

12. Down in the Display Window; click anywhere to place freezing drizzle symbols.

13. Try using the Undo ([image: image160.png]


), Redo ([image: image161.png]


), Move Glyph ([image: image162.png]


), and Copy Glyph ([image: image163.png]


) Icons.

14. Experiment with other Glyph Choices to familiarize yourself with the various features and options.

15. From the Main Toolbar, clear the GTAS Display Window.

WFO Only…
16. From the Server Selection Menu ([image: image164.png]GTAS (Backup) v



), select a server in order to view the weather data.

17. From the Obs Menu, select Station Plot.

18. From the Tools Menu, select the Drawing option. (When we cleared the Display in Step 14, the Drawing Tool was deactivated, so we are turning it back on.)

19. From the Drawing Toolbar, select New Drawing ([image: image165.png]


) to erase any glyphs left on the screen without erasing other data that might be displayed.

20. From the Drawing Toolbar, open the Glyph Choices Options Menu and select Fronts ([image: image166.png]Fronts




). Try to draw the various fronts that match the displayed data by clicking on the different front icons.

21. Once you have annotated an image, you can save it as a slide in a Slide Show, which will be discussed in Section 4.

22. From the Main Toolbar, clear the GTAS Display Window. 

23. From the Server Selection Menu ([image: image167.png]


), select “No Server”. Doing this step properly clears the cache and enhances performance for future GTAS use. 

24. From the File Menu, select Exit.

3.5 Using the Manual Graphics

Some adjustments may be made to elements of a manual graphic after they have been drawn by selecting the desired element, placing the tip of the mouse cursor on the element (glyph, annotation, line, etc.), and clicking once with the right mouse button. A pop-up menu will present options for changing the element, as shown in Figure 50.
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   Figure 50. Pop-Up Options Menu for Manual Graphics

4. Creating Weather Briefings (WFO only)
There are several tools available to help forecasters prepare and present weather briefings. The most commonly used tools are slide shows and procedures.  Slide shows allow the forecaster to create a series of slides that can include AWIPS Displays, special purpose text slides, web images and weather products downloaded from an internet server. Figure 51 illustrates the components of a briefing slide. The background image can be any JPEG, GIF, PNG, or even the current GTAS display. The text component is an html overlay. Slide shows are created on GTAS and are custom made for each weather briefing. They are played back using the GTAS slide show capability.  

[image: image169.jpg]



 Figure 51. Briefing Slide Components

Procedures allow forecasters to set up a sequence of forecast products that can be displayed in sequential or random order during a weather briefing. Once a procedure is set up, it can be used over and over again at different days to display the current data for that day. Forecasters can also display additional data (including graphical annotation) that is not part of the procedure without exiting the procedure.

4.1 Using the Slide Show Functions

The slide show user interface is designed to allow users to create individual slides and assemble them into a slide show. It is envisioned that the user would create these slide shows prior to a presentation and then play them back for the actual presentation. Individual slides can be created from data displayed on the screen (e.g. a radar loop with lightning data); images loaded from local disk or Web, or html text template files. The slide shows can be easily modified to change the contents of a slide or to add or delete slides. A special Dialog Menu is provided to create, modify, and display slides in a slide show.  

4.1.1 The Slide Show Dialog Box

The Slide Show Dialog Box is arranged so that you can move from top to bottom to create each slide in your slide show. Refer to Figure 52.
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Figure 52. Slide Show Dialog Box

· Slide Creation


In order to create a slide, the user must first select New Slide Show or View Slide Show from the File Menu and either give the slide show a name or select an existing one. This brings up the Slide Show Dialog Box that enables the creation and modification of a slide. The white area at the top of the dialog box contains a list of all of the existing slides (i.e Bundles). This area will be blank if a new slide show is being created. 

· Slides - This portion of the Slide Show Dialog Box lists the existing slides. When you initially open a new slide show, this portion is empty.
· Create Slide - In this portion of the dialog box, you can define the type of slide you want to create, and modify existing slides


· Slide Composition 

· Text overlay (Default) – This check box option when checked allows you to capture any text that was created when creating the slide for the slide show.
· Single-Frame Slide (Default) - This check box option when checked allows you to capture only one frame of a multiple data frame loop. For example, if you load 12 frames of the ETA model family, but you only want to capture the 36-hour forecast, just step to that frame and then click on the New Slide button. If this check box is unchecked, all 12 frames in the example above will be saved as a multiple data frame loop into the slide show. 

· Background image – This check box option when checked allows you to capture any data, drawings and/or images that are currently displayed in the GTAS display.

· Select Operation

Within this portion of the Slide Show Dialog Box are the control operations for manipulating the highlighted slide and the slide order. 


New Slide - When you choose this option, the contents of the screen will be converted to an image (JPEG) or a group of animated GIF images and stored. If you are creating a text slide, a listing of html templates will appear. Once you choose an html template file, the template will automatically be added to the slide show. To create a slide that contains an image background and text, first load the image background and then select New Slide. This causes the Template Dialog Box to be displayed. After selecting a template, the background and text template will automatically be saved as a slide. 

Rename - A slide can be renamed to give it a more descriptive name by selecting this menu button and entering the desired name. 

Replace - To replace the background image, first load the new background and then select the Replace Menu Button. This will replace the background (only) for that slide. 

Remove - To delete a slide, select the desired slide and click on the Remove Menu Button. 

Edit Text... - If the text is to be edited highlight the Text Overlay portion of the slide. This will cause the "Edit Text" selector to be highlighted which brings up a dialog box with all editable fields for that slide. 

Move Up/Move Down - To rearrange the order of the slides in your slide show, use the Move Up/Move Down Menu Buttons.

· Show Slide – To view slides in a slide show during a weather briefing or presentation, double-click on the starting bundle of the desired slide show, and then bring the main window to the foreground by clicking on the window frame. Press on the Load Menu Button to display the highlighted slide, and use the Previous and Next Menu Buttons to manually go backward and forward through the slide show. If you want to advance through the slides automatically, the user can specify the time delay between slides and enable the Auto-Load feature. 

4.1.2 Creating Custom Templates (Advanced Feature)

In designing the Briefing Tool, it was assumed that the creation of slide templates are an infrequent task and that generic templates can be generated that will meet the majority of needs. As a result, the creation of templates is considered an advanced feature and is not imbedded directly in the Briefing Tool. 

The Briefing Tool templates are in HTML format. Several HTML editors, such as Netscape Composer & Word Perfect exist that simplify the creation of HTML files. The following markers can be added when generating the text page.  Currently, the briefing tool cannot display an image or other link that is imbedded in the HTML file. 

The @@ symbol sequence is used to inform the Briefing Tool that it needs to parse the subsequent text for special instructions. A second occurrence of @@ terminates the text that is to be parsed. These fields will be displayed when selecting "Edit Text..." in the slide show menu. The following modifiable fields are supported by the Briefing Tool.   

0. Simple text field:

@@ text text text @@ 

Example: @@Enter wind speed@@ 
Example: Temperature:@@55 deg@@

1. Text field with color options (the first color is the default color)

@@ |color1|color2|color3=text text text@@ 

Example: @@|black|white=Hello World@@

2. Text field with color options (where the text is the name of the color)

@@text text text~color1|color2=color1@@ 

Example: @@Lightning~green|red=green@@

3. Text Matrices

@@any valid exp@@ @@_any valid exp@@ (Note the "_" to continue a row) 

Example (3 rows x 2 columns): 

Rule 1@@Now~green|red=green@@@@_T0~green|red=green@@ 

Rule 2@@Now~green|red=green@@@@_T0~green|red=green@@ 

Rule 3@@Now~green|red=green@@@@_T0~green|red=green@@

The template files are stored in FXC\fsl\data\templates\---Range\--- . These files are a permanent reference and stay unchanged when the user modifies their contents. Users can add their own subdirectories and/or html templates for their specific application.

4.2 Using the Procedure Functions

Procedures are created and modified in a very similar manner to slide shows. A major difference is that procedure bundles consist of only one component (graphic product) and therefore are simpler to modify. Also, procedures always load the most current data from the server instead of predefined slides. The data can include Web (URL) and local images. The auto-load capability can be used to continuously sequence through the bundles of a procedure. Each time a bundle is loaded, the most current data will be displayed. Like slide bundles, procedure bundles can also include frame animations. 
4.2.1 The Briefing/Procedure Dialog Box

The Briefing Dialog Box is very similar to the Slide Show Dialog Box in that it is arranged so that procedure bundles can be moved up or down to establish an order of display. The Briefing

Dialog Box enables the creation and modification of a slide. The white area at the top of the dialog box contains a list of all of the existing bundles. The existing bundles if any normally denotes a set of standardized bundles requested by the Emergency Operations Center (EOC). This area will be blank if a new briefing/procedure is being created. Refer to Figure 53 below.

In order to create or modify a Briefing, the user must first select New Procedure or View Procedure from the File Menu and either gives the Briefing a name of “Briefing”, if not already named “Briefing”, or selects an existing “Briefing”. By naming the Briefing “Briefing” enables the Briefees to see the Briefing created by the Briefer upon saving their briefing to the server. 
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Figure 53. WFO Briefing Dialog Box
· Bundles - This portion of the Briefing Dialog Box lists the existing bundles. When you initially open a new briefing/procedure, this portion is empty.
· Edit Bundle - In this portion of the dialog box, you can add, rename, remove, and replace new or existing bundles. You can also add a slide show, change the arrangement of the bundles by moving them up or down and save your bundles to the server so other users can access your briefing. Refer to Section 4.3 for a Briefing Practice Module. 
· Show Bundle - To view bundles, double-click on the desired bundle or press on the Load Menu Button to display the highlighted bundle, and use the Previous and Next Menu Buttons to manually go backward and forward through the bundles. Once a button is active, you can use your Enter key on your keyboard to step through the bundles. If you want to advance through the bundles automatically, the user can specify the time delay between bundles and enable the Auto-Load feature. With the Auto-Load feature enabled, the user can create JPEG images for the web by selecting the “Create JPEGs for web when auto-loading” option.   
4.3 Weather Briefing Practice Module

4.3.1 Creating an Intro Slide

Steps:

1. Open the GTAS display, if not already open.

2. Clear the GTAS display.

3. Connect to a Server by selecting either GTAS (Backup) or GTAS (Primary) from the Server Selection menu. If these choices were already selected, choose No Server and then re-select one of the Server options. 

4. From the File Menu, select New Slide Show…. Name the slide show “Intro Slide” in the space provided in the New Slide Show Dialog Box. 
5. In the Create Slide section of the dialog box, make sure the Text overlay and the Single-Frame Slide check boxes are enabled, then choose New Slide.
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Figure 54. Intro Slide Sample Dialog Box
6. When you select New Slide an Open Dialog Box appears. From the given .html templates that can be customized, choose the Title.html template and select Open. Upon doing this, a Title slide appears in your Intro Slide Sample Dialog Box.
7. Since the Title slide is the first slide in the slide list it is highlighted by default and since it contains a Text Overlay sub-section (click on the  + on the left side of the slide name to see the sub-sections), the text within the slide can now be edited and customized. Select Edit Text…, a Change Slide Text Dialog Box appears. 
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Figure 55. Change Slide Text Dialog Box

8. Change the text in the Change Slide Text Dialog Box to reflect the context of your Briefing and then select OK.
9. Close the Intro Slide Dialog Box. The changes that you made have been saved and will appear when you add this slide to your briefing. 
10. Clear the GTAS display. 

4.3.2 Adding the Intro Slide to a Briefing


Steps:

1. From the File Menu, select View Procedure. The Open Procedure Dialog Box appears. Select Briefing, if not already selected, and click OK. The Briefing Dialog Box opens. 
[image: image174.png]Open Procedure





Figure 56. Open Procedure Dialog Box

2. In the Edit Bundle section of the Briefing Dialog Box, select Add Slide Show. The Choose Slide Show Dialog Box appears. 
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Figure 57. Choose Slide Show Dialog Box

3. Select Intro Slide and then select OK. The Title slide now appears at the bottom of the bundle list. Select the Move Up option to move the Title slide to the top of the bundle list. 
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Figure 58. Briefing Dialog Box illustrating new Title slide location

4. So it is easy to distinguish between the standard EOC and actual WFO Briefing products, add a separator line to the bundle list. To do this, highlight the next bundle and click Load (or double-click on the bundle) to load the bundle. The loaded bundle will act as a place mark. Click Rename to rename the bundle. Name the bundle “----- End of Weather Briefing -----“. Refer to Figure 59 below. 
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Figure 59. Briefing Dialog Box illustrating Separator Line

4.3.3 Adding bundles/weather products to the Briefing
Steps:
1. From the Main Toolbar, change the Area scale selection menu to the CONUS scale and load the Obs Menu -> Station Plot.
2. From the Satellite Menu, load the Visible Satellite, change the Frame Count to 10, and turn on Looping.
3. From the File Menu -> View Procedure, re-open the Briefing Dialog Box, if not already open. 

4. In the Edit Bundle section, click Add to add the current GTAS display to the bundle list. Notice that the new bundle was appended to the bottom of the list. Use the Move Up option to move the bundle to the top of the list under the Title slide. 

5. Rename the new bundle “CONUS Visible Satellite, Station Plot”. Renaming the bundles make it easier for non-meteorologists to comprehend. You can also replace a bundle with the current display at anytime by clicking the Replace option. 
4.3.4 Saving the Briefing to the Server

Steps:

1. When you are satisfied with your Briefing, the next step is to save your Briefing to the server so that the EOCs and other clients can have access to your Briefing. 
2. With the Briefing Dialog Box open, select Save on Server to save your Briefing to the server. 
3. Close the Briefing Dialog Box. 

4. Clear the GTAS display.

5. From the Server Selection menu, select No Server.
6. From the File Menu, select Exit. 
5. Viewing a WFO Briefing (EOC only)

After the WFO creates a Briefing and saves it to the server, the EOC and other clients on the same server have access to view the Briefing. The Briefing consists of two parts within the Bundles list, the WFO products and the EOC standardized products. These products may or may not be separated by a separator line, so in this case it will be up to the WFO to determine between the products. The Briefing Dialog Box can be accessed through the File Menu -> View Briefing option, refer to Figure 60 below. 
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Figure 60. EOC Briefing Dialog Box

To display the products within the Bundles list, use the left mouse button to highlight a product and select Load, located in the Show Bundle section of the dialog or you can double-click on the highlighted product. The Previous and Next buttons allow moving to the next or previous bundle/products in the list. Every time a new product/bundle loads, it obtains the latest requested products from the server and displays it in real-time. To automatically step through the bundles list and load each product/bundle, check the Auto-load button and choose a Dwell time (sec). 
5.1 Viewing a WFO Briefing Practice Module

Steps:
1. Open the GTAS display if not already opened. 

2. Choose a Server from the Server selection menu.

3. From the File Menu, select View Briefing.
4. Highlight a product/bundle in the Bundles list and select Load or double-click on the highlighted product. Verify the chosen product/bundle displays. 
5. Clear the GTAS display and then close the Briefing Dialog Box. 

6. Select “No Server” in the Server selection menu.

7. From the File Menu, select Exit. 
6. “How to Collaborate” Practice Module
Steps:
1. Open the GTAS display if not already opened. 
2. Select Collaborate [image: image179.png]


, then select a Server from the Server selection menu. 

3. To verify you are connected collaboratively, select Tools->Text Chat…. If you are connected collaboratively you will be listed under Name in the Participants: section. From here, you can set up alarms to alert you when other desired participants are chatting in the text chat session. 
4. Close the Text Chat… window, if not already closed.

5. Clear the GTAS display.

6. Exit the Collaborate session by selecting “No Server” from the Server selection menu and then select Collaborate [image: image180.png]


. 

7. From the File Menu, select Exit. 
7. Working with HySPLIT

NOAA's Air Resources Laboratory is enhancing the Hybrid Single Particle Lagrangian Integrated Trajectory (HySPLIT) dispersion model with the Computer-Aided Management of Emergency Operations (CAMEO) chemicals database to enable HySPLIT to accurately model over 500 different types of hazardous substances. The Weather Research and Forecast (WRF) Nonhydrostatic Mesoscale Model (NMM) data is provided by NOAA's Global Systems Division (GSD) so that HySPLIT can more accurately model the trajectory and dispersion of the release. The WRF-NMM model output is ingested on GTAS NWS regional servers where the HySPLIT model is hosted. The GTAS servers are also populated with real-time weather data made available by NWS. Emergency managers and local forecasters are able to collaborate on toxic spills and weather hazards using GTAS' FSL X-Window Collaborate (FXC) workstation. FXC provides the net enabled operational interface to HySPLIT, WRF-NMM, and other meteorological data sets. These tools will provide emergency managers and forecasters the ability to quickly assess and provide more accurate response and mitigation plans to the public.
7.1 Running HySPLIT – Single Chemical and Location Practice Module

Steps:

1. Open the GTAS display, if not already opened.
2. Select a Server from the Server selection menu. 

3. Select Dispersion Model [image: image181.png]


 from the Main Toolbar. The Dispersion Model Dialog box to run HySPLIT appears.  
4. In the Start Time section of the dialog, choose Use current real time. 

5. For Total Run Time (hrs), select 3. Total Run Time (hrs) is the total weather model run time. 

6. For Model, select wrf, if not already selected.

7. In the Releases section of the dialog, select chlorine liquefied as the Chemical, 1.00 as the Duration and large railcar (33000 gal) as the Estimate. Duration is the HySPLIT model output time. 

8. If there are any highlighted chemicals in the Release Information box, remove them by selecting Remove. 

9. For the Lat and Lon characteristics, click From Map… and then use the left mouse button to select a location on the GTAS display. Leave the Hgt option as the default. 

10. Click Add to view the location and height characteristics in the Release Information box. Verify the information is correct and click Run. The runtime should take anywhere from 15 to 30 seconds for one chemical and location. Refer to Figure 61. 
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Figure 61. Example of HySPLIT run setup for One Chemical and Location

10. Close the Run Dispersion Model Dialog Box.
11. From the Main Menu Toolbar, select Dispersion -> “Office Type” -> Latest -> Image 1 to view the latest HySPLIT model run output. Verify the output is displayed in the GTAS display.

12. From the Main Toolbar, select [image: image183.png]


 and switch the Frames to 8 to see more of the output.  

13. Clear the GTAS display.

7.2 Running HySPLIT – Single Chemical, Multiple Locations Practice Module

Steps:

1. Clear the GTAS display, if not already cleared and make sure you are connected to a Server. 
2. Select Dispersion Model [image: image184.png]


 from the Main Toolbar. The Dispersion Model Dialog box to run HySPLIT appears.  

3. In the Start Time section of the dialog, choose Use current real time. 

4. For Total Run Time (hrs), select 3. Total Run Time (hrs) is the total weather model run time. 

5. For Model, select wrf, if not already selected.

6. In the Releases section of the dialog, select (unknown), unknown can be used to simulate a Fire, as the Chemical, 1.00 as the Duration and facility (6100 gal) as the Estimate. Duration is the HySPLIT model output time. 
7. If there are any highlighted chemicals in the Release Information box, remove them by selecting Remove. 

8. For the Lat and Lon characteristics, click From Map… and then use the left mouse button to select a location on the GTAS display. Leave the Hgt option as the default. 

9. Click Add to view the location and height characteristics in the Release Information box. Verify the information is correct. 

10. Repeat Steps 8 and 9 for multiple locations. 

11. Click Run to run the HySPLIT model. The items in the Release Information box do not have to be highlighted in order to run all items simultaneously. The runtime should take anywhere from 15 to 60 seconds for one chemical and multiple locations. Refer to Figure 62. 
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Figure 62. Example of HySPLIT run setup for One Chemical and Multiple Locations

12. Close the Run Dispersion Model Dialog Box.

13. From the Main Menu Toolbar, select Dispersion -> “Office Type” -> Latest -> Image 1 to view the latest HySPLIT model run output. Verify the output is displayed in the GTAS display.

14. From the Main Toolbar, select [image: image186.png]


 and switch the Frames to 8, if not already at 8 frames, to see more of the output.  Figure 63 below illustrates the HySPLIT output. 
15. When finished viewing the HySPLIT model output, clear the GTAS display.
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Figure 63. Illustrating HySPLIT output for One Chemical and Multiple Locations

7.3 Running HySPLIT – Multiple Chemicals, One Location Practice Module

Steps:

1. Clear the GTAS display, if not already cleared and make sure you are connected to a Server. 

2. Select Dispersion Model [image: image188.png]


 from the Main Toolbar. The Dispersion Model Dialog box to run HySPLIT appears.  

3. In the Start Time section of the dialog, choose Use current real time. 

4. For Total Run Time (hrs), select 3. Total Run Time (hrs) is the total weather model run time. 

5. For Model, select wrf, if not already selected.

6. In the Releases section of the dialog, select butane as the Chemical, 1.00 as the Duration and large railcar (33000) as the Estimate. Duration is the HySPLIT model output time. 

7. If there are any highlighted chemicals in the Release Information box, remove them by selecting Remove. 

8. For the Lat and Lon characteristics, click From Map… and then use the left mouse button to select a location on the GTAS display. Leave the Hgt option as the default. 

9. Click Add to view the location and height characteristics in the Release Information box. Verify the information is correct. 

10. In the Releases section of the dialog again, select ethane as the Chemical, 1.00 as the Duration and large railcar (33000) as the Estimate. Duration is the HySPLIT model output time. 

11. For the Lat and Lon characteristics, since we are simulating a release with multiple chemicals at the same location it is easiest to type in the previous Latitude and Longitude information, added to the Release Information box, into the new Lat: and Lon:. Leave the Hgt option as the default.

12. Click Add to view the location and height characteristics in the Release Information box. Verify the new information is correct.
13. Click Run to run the HySPLIT model. The items in the Release Information box do not have to be highlighted in order to run all items simultaneously. The runtime should take anywhere from 15 to 60 seconds for multiple chemicals and one location. Refer to Figure 64. 
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Figure 64. Example of HySPLIT run setup for Multiple Chemicals and One Location

14. Close the Run Dispersion Model Dialog Box.

15. Since Chemicals are viewed as Images in GTAS in order to see both images/chemicals at the same time, you will need to Combine Images before loading the HySPLIT output. To Combine Images, select Options from the Main Toolbar -> Image Properties… and then enable Combine Images by checking the check box. Close the Image Properties Dialog Box. 

16. From the Main Menu Toolbar, select Dispersion -> “Office Type” -> Latest -> Image 1 and then select Dispersion -> “Office Type” -> Latest -> Image 2 to view the latest HySPLIT model run output. Verify the output is displayed in the GTAS display and also verify each HySPLIT chemical is listed in the product legend. 
17. From the Main Toolbar, select [image: image190.png]


 and switch the Frames to 8, if not already at 8 frames, to see more of the output.  
18. When finished viewing the HySPLIT model output, clear the GTAS display.

7.4 Running HySPLIT – Multiple Chemicals, Multiple Locations Practice Module

Steps:

1. Clear the GTAS display, if not already cleared and make sure you are connected to a Server. 

2. Select Dispersion Model [image: image191.png]


 from the Main Toolbar. The Dispersion Model Dialog box to run HySPLIT appears.  

3. In the Start Time section of the dialog, choose Use current real time. 

4. For Total Run Time (hrs), select 3. Total Run Time (hrs) is the total weather model run time.

5. For Model, select wrf, if not already selected.

6. In the Releases section of the dialog, select chlorine liquefied as the Chemical, 1.00 as the Duration and large railcar (33000) as the Estimate. Duration is the HySPLIT model output time. 

7. If there are any highlighted chemicals in the Release Information box, remove them by selecting Remove.

8. For the Lat and Lon characteristics, click From Map… and then use the left mouse button to select a location on the GTAS display. Leave the Hgt option as the default. 

9. Click Add to view the location and height characteristics in the Release Information box. Verify the information is correct.

10. Repeat Steps 8 and 9 to simulate the same chemical at two different locations. 

11. In the Releases section of the dialog again, select chlorine dioxide as the Chemical, 1.00 as the Duration and large railcar (33000) as the Estimate. Duration is the HySPLIT model output time.

12. For the Lat and Lon characteristics, click From Map… and then use the left mouse button to select a location on the GTAS display. Leave the Hgt option as the default. 

13. Click Add to view the location and height characteristics in the Release Information box. Verify the information is correct.

14. Click Run to run the HySPLIT model. The items in the Release Information box do not have to be highlighted in order to run all items simultaneously. The runtime should take anywhere from 15 to 60 seconds for multiple chemicals and multiple locations. Refer to Figure 65.
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Figure 65. Example of HySPLIT run setup for Multiple Chemicals and Multiple Locations

15. Close the Run Dispersion Model Dialog Box.

16. Since Chemicals are viewed as Images in GTAS in order to see both images/chemicals at the same time, you will need to Combine Images before loading the HySPLIT output. To Combine Images, select Options from the Main Toolbar -> Image Properties… and then enable Combine Images by checking the check box. Close the Image Properties Dialog Box. 

17. From the Main Menu Toolbar, select Dispersion -> “Office Type” -> Latest -> Image 1, this displays the last item in the Release Information box. The last item in the Release Information box is a different image/chemical and location than the first two items so it is saved as the Latest run. The first two items in the Release Information box are the same chemical/image with different locations so they are saved as one image and as RUN 2. The first two items can be accessed by selecting Dispersion -> “Office Type” -> RUN 2 -> Image 1. 
18. Verify the output displays in the GTAS display and also verify each HySPLIT chemical is listed in the product legend. Refer to Figure 66 below. 
19. From the Main Toolbar, select [image: image193.png]


 and switch the Frames to 8, if not already at 8 frames, to see more of the output.  

20. When finished viewing the HySPLIT model output, clear the GTAS display.

21. From the Server selection menu, select “No Server”. 

22. From the File Menu, select Exit. 
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Figure 66. Illustrating HySPLIT output for Multiple Chemicals and Multiple Locations

8. Creating and Disseminating a CAP Message Practice Module

Play Video
Steps:

1. Open the GTAS display, if not already open, and select a Server through the Server selection menu.

2. Activate the Drawing Tool bar by clicking Ctrl-D or by selecting Drawing through the Tools Menu on the Menu Toolbar. 

3. Select Shapes (Glyph Choices selection menu) -> Polygon.

4. To start drawing the polygon, click and drag with the Left Mouse Button. When finished with the polygon, close it with the Right Mouse Button. A polygon must be drawn in the display in order for the Create CAP Message GUI to be enabled.

5. Next select CAP from the Drawing Toolbar, the Create CAP Message GUI appears. 
6. Fill in the desired areas, Red bullets are Mandatory and Green bullets are Optional, and click OK. The CAP feature needs to be configured per site in order to be disseminated to a vendor(s).

7. Verify the message was created by selecting Tools->Text Window... and then selecting File->Open...->logs (go up one directory)->CAP_*.xml.
9. Querying the GIS Map Backgrounds Practice Module
Steps:

1. Open the GTAS display, if not already open, and select a Server through the Server selection menu.

2. On the Main Toolbar, select a Scale from the Area selection menu. 

3. From the Maps Menu, select Streets->"State (By County)"->"an available county" for that particular Scale. 

4. Click the Right Mouse Button on the “Map Name” in the Product Legend, located in the lower right corner of the display, and select Change Display Properties... (the maps that are shape files will only have this option), the Shape file Display Properties GUI appears. Notice the “Map Name” of the shape file appears in the Shape file: box. 

5. In the Feature Colors: area, select a Determining Property: for the shape file. The Determining Property, once selected, illustrates the records available in the Colors for Values: area for that attribute/property.
a. Within the Colors for Values: area, there are three columns:
i. Values - displays the attribute/property value/record for the shape file
ii. Visible - when enabled allows the property to be displayed
iii. Color - can change color by double clicking and selecting a color
b. Practice selecting multiple records within the Colors for Values: area by clicking with the Left Mouse Button on the first (blank) record and then while holding Shift click on another record or use Ctrl + Left Mouse Button to select or de-select multiple records. 
6. In the Find: box, start typing the name of a record/value that would likely be a record in the list of records. The record/value entered is now highlighted. 
7. Select the Color... button on the left side of the GUI and pick a color. Verify the color selected is now the color of the record or value. The color selected will appear under the Color column.
8. If the Property is a number field, the values/records can be queried into a desired Range of numbers. The values can also be Split to automatically put the values/records into a range and then Combined again to reflect the original state. 
9. To enable or disable labels, click on Show Annotation Labels
a. If enabled, can configure how the labels will appear on the display by changing the font, font size, and color of the label. There are also options to make the label appear bold or italic.

10. When finished querying the maps, close the Shape file Display Properties GUI.

11. Clear the GTAS display and select No Server from the Server selection menu.

12. From the File Menu, select Exit.
10. Additional Practice Modules for GTAS
(WFO only)
10.1 Copying a Procedure/Briefing to another Procedure/Briefing 

Steps:

1. Open the GTAS display, if not already open.
2. Select a Server from the Server selection menu. 

3. From the File Menu, select Copy Procedure. 
4. Select a Procedure to copy in the Procedures to be Copied Dialog Box and select OK.
5. Name the new procedure "Briefing" and select OK. The Briefing Dialog Box opens. These steps allow users to copy another procedure not named Briefing to Briefing so that it can be saved to the server and so that other GTAS clients connected to the same server can view it. 
10.2 Creating a New Slide Show and an Image Slide
Steps:
1. From the File Pull-Down Menu in the Menu Bar, select New Slide Show. This should bring up a dialog box that prompts you for a name for the slide show. After entering the name, the large Slide Show Dialog Box will appear with no slides listed in the white area of the dialog box. Also, note that the words "Slide Show" have been added in the top border of the main window.

2. Now, from the Satellite Pull-Down Menu in the GTAS, load 4 frames of IR Satellite data on the CONUS scale. These data will be used to create your first slide.

3. Back in the Slide Show Dialog Box, open the Select Slide Type Options Menu and choose "Image Slide Only."
4. Ensure that the Single-Frame Slide Button is disabled.

5. Press the Create Slide Menu Button and observe that the "IR Window" slide appears in your Slide Show List.

6. Click on the lever icon next to the IR Window slide and note that there is no text for this slide and there are 4 background images.

7. Clear the IR Satellite image from the GTAS Display.

8. Keep the Slide Show open for Objective 2. Please note that your slide show is saved with each action, so the slide show you are generating won't be lost.

10.3 Creating a Text Slide
Now that you have created an image-only slide, let's add a text-only slide to your slide show. The text will be generated from predefined text templates. 

Steps:
1. In the Slide Show Dialog Box, open the Select Slide Type Options Menu and choose "Text Slide Only."
2. Press the Create Slide Menu Button. Immediately a dialog box appears from which you can choose a text template. From the EasternRange file, select the Airmass.html file and depress the Open button.. Observe that the textual information appears in the GTAS Display. Note also that a new "Airmass" slide is in your Slide Show.

3. Click on the lever icon next to the Airmass slide and note that there is a Text Overlay and no background images for this slide.

4. Clear the Airmass text information from the GTAS Display.

5. Keep the Slide Show open for Objective 3.

10.4 Adding a Background to the Text Slide
A limited set of predefined backgrounds, such as logos and solid colors, are available. Any jpg, png, or gif image is a candidate for the background. Additionally, any meteorological data currently displayed on the screen can be used for the slide background.. 

Steps:
· Any Slide Type Option is a valid choice. No special selection is required.

· Highlight the "No Background Image" by selecting the background component of your Airmass slide.

· From the GTAS Tool Menubar select File and then GIF/JPG/PNG
· This will pop open a new File Selection Menu. Select ER_logoBar.jpg and depress the Open Button.
· The Eastern Range logo will appear on the screen. Click on the Replace Button on the Slide Show Menu. The image name will replace "No Background Image" and the combined text and background will be displayed on the screen.

· Keep this Slide Show open for Objective 4.

10.5 Creating a Combined Image and Text Slide (Alternate Approach)
This module describes an alternate approach to creating a text slide with an image background. For the background, you may use the image on the screen or a colored background of your choice, as long as it is in jpg, png, or gif format. 

Steps:
1. In the Slide Show Dialog Box, open the Select Slide Type Options Menu and choose "Image and Text."
Important!  The desired image must be loaded before clicking on the "Create Slide" button. Whatever is displayed on the screen, be it a Satellite image or another text slide, will become the background for the new slide. If a text slide is currently displayed, it will become the background for the new slide.
2. From the GTAS File Pull-Down Menu, select the GIF/JPEG/PNG Background option. Immediately a dialog box opens from which you can choose from an assortment of pregenerated image files. For this example, please select the WR_logoBar.jpg file. The image will appear in the GTAS Display.

3. Press the Create Slide Menu Button. This brings up the Text Template Files Menu. For this example, please choose delay.html. Note how the textual information is overlayed onto the logo bar image.

4. If you would like to change the name of the slide click on the Rename Menu Button to open the Rename Slide Dialog Box  Type in "24-hr Delay" for this third slide.

5. Click on the lever icon next to the 24-hr Delay slide and note that there is a Text Overlay and one background image for this slide.

6. Keep the Slide Show open for Objective 5.

10.6 Editing Text Within a Slide
In most cases, the text templates will need to be modified to your current weather scenario. This is easily accomplished as the following steps will show. 

Steps:
1. In 24-hr Delay Slide, click on the Text Overlay. The Edit Text... Menu Button becomes active.

2. Click on the Edit Text... Menu Button. Immediately the Change Contents of Fields Dialog Box opens, containing the predefined fields of the 24-Hour Delay Template. Use the Tab Key on your keyboard to navigate through the various fields. Feel free to modify several fields.

3. When you are finished editing the fields, press the OK Menu Button, and note the changes automatically reload in the GTAS Display.

4. Using the Move Up and Move Down Menu Buttons, you can reorder the slides as needed.

5. Now, press the Close Menu Button to close your new slide show. Remember, the system automatically saves it.

6. From the GTAS Main Toolbar, press the Clear Icon Button to clear the GTAS Display.

10.7 Playing Back an Existing Slide Show
This module explains how to play back the newly created slide show and demonstrates image animation within a slide show. 

Steps:
1. From the Menu Bar select the File Pull-Down Menu and select the Open Slide Show option. The Open Slide Show Dialog Box appears and contains a list of the names of existing slide shows. After selecting the desired show (the one you created above), the large Slide Show Dialog Box will appear with a list of the slides (Bundles). Also, note that the words "Slide Show" have been added in the title bar of the GTAS Display.


Important!  Depending on the desktop environment of some Linux systems, your slide show may open but is iconified in the desktop toolbar. If this happens, simply open the desktop toolbar and double-click on your slide show name.
2. Select the first slide by double-clicking on the name of the slide. This will cause the first slide to be displayed. An alternate method for displaying the slide is to click once on the name of the slide and then selecting the Load Menu Button in the Slide Show Dialog Box.

3. Advance to the next slide by pressing the "Down Arrow" on the keyboard, or by clicking on the Next Menu Button in the Slide Show Dialog Box. The second slide containing the text information is displayed.

4. You can advance through the slide show automatically by selecting the Auto-Load Check Button and choosing the desired time interval between slides from the Options Menu next to the Auto-Load Check Button. Keep in mind that slide containing more data may need more time to display, and this may need a longer time interval between slides.

5. To exit the slide show, select the Close Menu Button at the bottom of the Slide Show Dialog Box.

10.8 Inserting a Text Slide into a Procedure

This module explains how to take an existing slide from a slide show and make it part of a procedure. Note: A procedure always retrieves the most current data from the data base while a slide show gets its displays from fixed jpg images. As a result, the displays created by a procedure will most likely be different each time the procedure is used, while the displays in a slide show will be exactly the same every time it is executed (unless the user modifies a slide). 

Steps:
1. Using the steps described in Module 6 display the desired text slide.

2. From the Menu Bar select the File Menu, and then select New Procedure...
3. In the pop-up menu enter Test for the name of the new procedure, and click on OK.

4. This will cause the procedure window to appear (It will be labeled "Test" at the top)

5. Click on the Add Button. This will add the slide to the procedure.

6. To exit the procedure, select the Close Menu Button at the bottom of the Procedure Dialog Box.

11. Uploading User Shape Files  

This section provides detailed information on how to upload User shape files onto the GTAS display and Menus using the GTAS Upload User File Interface, see Figures 67-70 below. 
11.1 Running the GTAS Upload User File Interface
11.2 Uploading a File
[image: image195.png]TAS Upload User File.

P Biowse
Map Nare:

Submit





Figure 67. GTAS Upload User File Interface

This interface allows a User to upload their own shape files under the condition that the following initial requirements are met…
1. Each shape file must be zipped and individually uploaded using the Browse button.

2. Each zipped file must contain .xml, .shp, .dbf, and .shx file formats.
3. The .dbf table attribute field sizes must be less than 254. Users can check the field size by opening the .dbf file in a Microsoft Excel workbook. Highlight the column(s) and use the right mouse button to select Column Width…. If the column width is less than 254, the file will work with the GTAS software.

11.3 Choosing Field Attributes
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Figure 68. Choosing Field Attributes of New File
After a User uploads a zipped shape file using the Browse button and then selects Submit, a User can then choose field attributes to display in the Change Display Properties GUI (see Section 3.1.12 for more information). To choose field attributes, use the Left Mouse Button and click in the “Text” box, where “NAME” is currently the default, and select additional field attributes to KEEP for “future” querying and reference. The remaining non-selected field attributes will be removed.  
11.4 Customizing Menus
The last step of uploading User files is choosing and customizing the Menu placement of your file(s). After choosing additional field attributes to keep, a User can then select, add, or edit which Headings and/or Menus to place the new file(s) in. 
To add a new Heading or Menu, double click with the Left Mouse Button and add the new text once the “Add Heading” or “Add Menu” becomes highlighted. 
To remove an unwanted Heading or Menu, use the Right Mouse Button Pop Up Menu and select Remove, note that the Heading or Menu must not have any sub-headings or sub-menus associated with it.    
Select Submit to complete the uploading of the file to GTAS.
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Figure 69. Customizing Menu Placement of New File
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Figure 70. Result of Successful Upload
12. Useful Tips

This section provides some tips and suggestions on how to create special displays and in some cases, simplify operational procedures.

12.1 Creating Text Slides with a Background (WFO only)
It is considerably simpler to always create text slides using the "Text Only" option (and subsequently loading the logo image and replacing the background) then to use the "Image and Text" option. Using this approach, the user first creates the desired text slides and, when satisfied, adds the appropriate backgrounds to the slides.

12.2 Creating a Graphic overlay (such as a flight path)

This can be done by using the drawing tool to draw a line on a map background and saving it as Graphic X, where X=(1,2,3….,12).  To save Graphic X, use the Tools->Tool-specific Commands->Save Drawing menu.  This graphic is geo-referenced and can be overlayed on a satellite image or other data by loading "Local Graphic X" under the "Obs" menu. Currently, there is no "Range and Azimuth" support to help draw the line.

12.3 Saving Screen as a JPEG Image

The size and aspect ratio of the newly created JPEG image is the same as that of the GTAS Display Window. Thus, to obtain the best image quality it is suggested that the GTAS Window be adjusted to closely resemble that of the desired JPEG image before saving the screen. For some applications it may be desirable to specify a fixed width of the image. The user can set the "JPEG Resolution" (under File menu) to the desired width and have the software compute the appropriate height.

12.4 Procedures to Monitor Weather 
GTAS procedures have several additional features that are not found on AWIPS. Procedures can be used to continuously monitor data or brief remote users. For example, a procedure can be created that routinely displays the local radar (AWIPS), a video cam (Web), and a graphical hazard product to local and remote users. This is done by enabling the "Auto load at x seconds" selector in the procedure dialog window.
12.5 Selecting Collaborative Mode

When connecting to a server in the collaborative mode, it is faster to depress the Collaborative Button first, and then select the desired server. The reason for this is that the private and collaborative servers are separate and distinct. Thus, if the server is selected first, a connection with the private server will be established first and then broken when the Collaborative Button is depressed (in order to connect to the collaborative server).
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Figure 3. WFO File Menu
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